Bootloader Vulnerability Affects Nearly All Lin… » Linux Magazine

0
6


CVE-2023-40547 has a CVSS score of 8.3, which means it’s labeled as High. Originally, the vulnerability was given a score of 9.8 (which placed it in the Critical category) but that has since changed.

This vulnerability was discovered in shim, which is a small application that loads prior to the main operating system bootloader (such as Grub) on UEFI-based systems.

The flaw could allow an attack to create a specific HTTP request that could enable a controlled out-of-bounds write primitive, which could lead to complete system compromise.

According to Bill Demirkapi (from the Microsoft Security Response Center), the bug exists in every Linux bootloader signed in the past decade.

The official description of the issue explains, “When retrieving files via HTTP or related protocols, shim attempts to allocate a buffer to store the received data. Unfortunately, this means getting the size from an HTTP header, which can be manipulated to specify a size that’s smaller than the received data. In this case, the code accidentally uses the header for the allocation but the protocol metadata to copy it from the rx buffer, resulting in an out-of-bounds write.”

Fortunately, all major distributions have released patches for the vulnerability, so users only need to run an update on their systems to avoid being exposed to the issue.
 
 
 

 
 
 





Source link